View Single Post
Old 04-07-2013   #4
Steveedee
Registered User
Newbie Member
 
Join Date: Mar 2013
Posts: 2
Steveedee is an unknown quantity at this point
this is what worked for me

I have been dealing with this as well, here's what worked for me. I have a GTX 680 in my custom watercooled OC i7 2600k rig and a GTX 670m in my Asus G75VW laptop, both on ssd, both with 16gb RAM. When I read about people with better set ups getting worse fps it gives me hope because I know it is just a matter of optimizing my set up manually. You should have hope too, people who know way more than I do are really pissed about this and are working on it as well, we stand on the shoulders of giants. Rockstar made the worst BEST game ever with GTAIV and it takes professional programmer/modders to undue their incompetence.

Without filming in Fraps my fps jumps a lot lately because I have every car in the game modified and a few have caused memory leaks I am tracking down. but that is my problem, let me try to help you with yours. This is a collection of what has worked for me, i get up to 78 FPS and down to 35 depending on draw distance, weather, popcycle density (I use moreliberty 3). I use a good enb for lower end computers to avoid wasting resources, Icenhancer is sweet but kills my rig. I use Vulgadrop's ENB:
http://www.gta4-mods.com/misc/1070-enb-graphic-mod-21c-f10162

First, remember you need to trick GTA4 how to actually use your hardware because it is seriously blind to it, it is frustrating but it is possible.

I use Fraps to check my frame-rate, I use Process Lasso to watch my cpu/mem usage on a separate monitor and I set a GTA4 profile in Process Lasso for gaming, high performance, and to avoid threaded cores.

I Set my windows power profile both computers to performance, I removed all virtual optimization software - its all crap and confuses the game as to which memory and process or to utilize

If you can disable your integrated video card do so, in the bios, if not then NEVER set your computer off performance. Worried about battery life and killing the environment? Wrong game.

Set your virtual memory to the lowest available, 32mb? Windows will enable your virtual memory over your dedicated video memory and GTA4 will not see/use it either unless you force it to.

I removed hibernation and deleted my pagefile from my desktop but left hibernation on my laptop.

In my Nvidia Manage 3D Settings I set it to:

Power management mode - prefer maximum performance
texture filtering - clamp
threaded optimization - on
vertical sync - off (set the Vsync on in the ingame Graphic menu)

The jury is out for me between my PhysX settings, my instinct is with the 680 but Rockstar built this game for the CPU to do the heavy lifting so I opt to set it to CPU

This helped: http://en.kioskea.net/forum/affich-8...ta-iv-too-slow

I unparked all my cores with UnparkCPU:

and this: URL="http://forums.bit-tech.net/showthread.php?t=229080"]http://forums.bit-tech.net/showthread.php?t=229080 [/URL]

Hope it helps. I have great game play when my modded cars aren't glitching out my game...
Steveedee is offline   Reply With Quote